LectorRSS actualización 1.3.1

Se me olvidó poner el espere por favor que estamos actualizando, lo cual podría ocasionar dos cosas si tarda demasiado en actualizar (he vuelto a actualizar antes de publicar esto, está explicado aquí mismo), a saber:

    Que el usuario pensase que LectorRSS se había colgado y maldijese al programador, o sea: yo.

    Que android pensase que LectorRSS se había colgado por tardar demasiado en responder, no recuerdo el nombre que tiene esta situación en este sistema (ANR creo que es en sus siglas en inglés), por lo que cerraría el programa y el usuario maldeciría al programador, o sea: yo.

Además he cambiado otra cosa. Para ver si existe conexión o no, y que no salga un cierre forzoso de la aplicación, uso este método

boolean comprobarConexion(Context context){
ConnectivityManager cm = (ConnectivityManager)context.getSystemService(Context.CONNECTIVITY_SERVICE);
return (cm.getActiveNetworkInfo() != null && cm.getActiveNetworkInfo().isAvailable() && cm.getActiveNetworkInfo().isConnected())
? true : false;
}//Fin comprobarConexion();

en una clase llamada ConexionesINet. Hasta ahora lo usaba como método estático y de vez en cuando parecía no reconocer que se había recuperado la conexión. Es decir que si intentabas una acción que requiriese acceder a internet (actualizar, añadir una nueva fuente, visitar un enlace) y no había conexión y al siguiente intento sí la había, a veces este método parecía no darse cuenta. Creo que era por ser estático (¿?). Lo he puesto como método normal, creo un objeto de la clase para acceder a él y por lo que llevo probado parece funcionar bien. Así que actualizo también esto.

No esperaba resubir el programa tan pronto, pero que se le va ha hacer.

Estooooo, he hecho una pequeña trampa. Usando el mismo número de versión cara al público he vuelto a subir la aplicación minutos después por otro estúpido fallo.
Antes de darme cuenta de lo del aviso de que se está actualizando había empezado ha hacer algunos cambios y entre ellos había dejado de inicializar una variable al intentar mostrar una entrada en el canal de nuevas. Como os lo podría decir….al ponerme con lo otro se me olvidó lo esto….

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s